Forum Navigation
You need to log in to create posts and topics.

ST v1.5.0 appcrash and vst loading problem

I use ST v1.5.0 on W7 since last month.

Every time as I try to quit the program, I will be prompted to specify the location of my source file to be saved and after doing that (saving the file), I get a message of an app-crash. (But source file has been existing before that in session folder)

I already tried to delete st.pref and STsetup files. No effect.


I am also not able to load any vst in the aux channel.

Where can I specify the folder location of my vst-fx? (Inside the app?)

I read about the same problem of another user and tried to specify the location in the st.pref-file, but the file will be overwritten by ST every time I start the program. So I created the folder specified in the st.pref-file and copied a VST-dll (dearVR Ambi micro) into it, but it won't load neither. When I click on the list (vst in AUX channel) nothing happens.

BTW: I asked myself if I could use the  Ambiconverter of Cubase 10 PRO in this AUX slot if it will finally work.

Can I get an update with bugfixes? ST seems to be a fantasic app, but for me right now at this point not worth the money as I am not working with a big speaker array.


Thank you for your help!


Unfortunately, the ST version for Windows 7 is not stable. This is due to the libraries that make it possible to design ST that abandons W7 to optimize proper operation under W10.

Have you tried version for windows 10, even under windows 7? There must be some error messages, but the application still works.

I encourage you to use ST with windows 10 because the next updates will not support W7.

The next updates are scheduled for October

Thank you for your instant reply, Max,

Meanwhile I tried ST10.5.0.1 on Windows 7.

Now I can see the vst in a specific folder in the AUX-menu of the mixer and I can load them up, which is great!

But: I tried to record some audio with the AUX record function. The result was: in stereo mode the wav-file was empty, and in multi-mode the file could not be recognized by my DAW (Cubase 10 Pro).  (If you could solve that problem for me, it would be great!!)

Also it seems strange, that the input and output assignment I choose to have is always reset to the logical order of my sound-card (RME Fireface) when I reload the session file. (That is potentially a big problem, that causes me to have feedback since using the loopback function of Totalmix.)

I am using a lot some software which is not available on W10, so I would like to keep W7 as long as possible.

Thank you for your help!





Hello Max!

Is the new update of ST out now? Would be happy if I could use my app now without limits...


Thank you!



November 1st, good hope that all problems will be solved