Forum Navigation
You need to log in to create posts and topics.

Unable to launch the application


The program is unable to launch in any native or compatibility mode, not even a splash screen. I tried a lot of things and different workstations. It actually never did on any version, just didn't have time to check it out and to post it here.



My system:

Windows 10 Pro Build 1803 (but it didn't work in any other builds for some reason)

i7 5960x / 64Gb / Nvidia Titan X

Lynx AES16 ASIO interface




Hello Shandor

Normally Sound Trajectory runs on Windows 7, 8 and 10 without problems but in 64bits only.

However in some cases the program may be blocked during installation or execution.

Is the installation or the installed program the problem?
Can you confirm that the installer is for the version?

During installation, Windows may display a warning for "unknown editor" and block the installation of Sound Trajectory. The program must be allowed to be installed. (Windows Defender SmartScreen )

Do you use an antivirus? The program can be blocked by some antivirus. you must then authorize the program to be executed.

Did previous versions of Sound Trajectory work on your machines?

We'll find the problem, thank you for your patience.



Hey Max,


No problems. I am also into creative coding and I know all the caveats of the process, so just letting you know what's happening 'cuz I think that if it works as conceived, it can be a potentially amazing piece of software! So, keep on fighting those nasty bugs.

Btw, I'm French (Paris) but writing in English so it would be helpful for your future international community.

Anyway, about our business:

Indeed, I wasn't using the version which was posted when? (Btw, I would improve the visibility of versions and files to download on the website for more clarity). I was using version without installer (just copying the files).

Unfortunately, sad to report that the result is the same: in Task manager Sound Trajectory process begins loading and going quickly up to 649Mb then going directly 1Mo and disappears, all that being completely silent: no splash screens, no error notices, no nothing.

To answer your questions:

  • I use windows defender protection which I find equal or better than commercial anti-virus. Nothing is blocked and smartscreen is always authorized.
  • I tried to run it in compatibility mode and as administrator. Nothing happens. Well, one thing: when executing as administrator, the memory footprint grows up to 1200Mb (-ish) instead of 700 in non administrator mode. Then, it just shuts down silently.
  • 1 time in 10 of my trial, windows proposes to run the program in compatibility mode, but none of the parameters makes the app launch.
  • Sorry to report that none of the versions I tested (initial release, then perhaps 103 and now 107) did't work on any of my machines: studio desktop, laptop, transformer pad.

Thank you




Thank you for the full report and sorry for that.

I have a little idea of probable cause.

Can you try a new  installation with this installer (107-C) :

You will probably need to manually uninstall all older versions.


Oh man! That's it.

It took some time to open and I was about to write that it didn't work, but it finally did!

Looks like a promising start for a hot looking software! Opengl and everything 🙂

There's quite a lot of lag switching between different views, but that's another story for another time.

So, max you did it! You can go get a beer now 🙂




Thanks ! Next step soon with official update